邮件归档软件升级到MailStore Server 23.1.2,才能继续支持Let’s Encrypt

作者:mailstore,发布时间:2023-05-19 22:03:00

mailstore,Let’s Encrypt,邮件归档

从4月24日起,您需要在系统上安装MailStore Server 23.1.2版本才能继续使用Let’s Encrypt

Let’s Encrypt宣布它将于2023年4月24日永久改变申请证书的流程。请在这里阅读Let’s Encrypt的声明。从这天起,使用MailStore Server 23.1或更早版本的软件的用户将无法续订现有的Let’s Encrypt证书或申请新的证书。虽然当前有效的证书将在4月24日之后仍然有效,但这些证书将在其有效期结束时到期。之后,只有当管理员手动更改证书时,才能访问邮件归档MailStore Server。即使现在,测试环境也不允许申请测试证书。所以,您需要采取行动。

Let’s Encrypt证书用户需要做什么?

Let’s Encrypt宣布的变更意味着您需要切换到我们最新版本的软件,即MailStore Server 23.1.2。要更新到MailStore Server 23.1.2,您需要有一个活动的更新和支持服务。

如果您已经使用MailStore 23.1.2,则无需进一步操作,因为此版本的MailStore Server已经支持新的Let’s Encrypt方法,您可以像以前一样自动申请或续订证书。

如果不更新到新版本的MailStore Server会发生什么?

如果您不更新到23.1.2或更高版本的MailStore Server,当您尝试设置Let’s Encrypt时,我们的软件将返回以下错误代码:_Certes.AcmeException: Fail to finalize order._仪表盘和状态报告中的警告将提醒您现有的Let’s Encrypt证书无法续订。

您将无法申请或续订证书。此外,如果您当前的Let’s Encrypt证书过期且无法续订,您将无法通过MailStore客户端或MailStore Outlook插件调用存档。

如果您不再想使用Let’s Encrypt证书,您可以考虑创建自己的自签名证书或使用现有证书。

Let’s Encrypt实际上做什么以及为什么如此有用?

Let’s Encrypt是一个独立的证书颁发机构,免费提供用于传输层安全性(TSL)加密的数字证书。您可以自动申请和续订这些证书,并在MailStore Server中使用它们。这意味着当从移动设备访问存档时,诸如用户ID和密码以及电子邮件内容等安全性关键数据可以被加密并使第三方无法访问——即使在未受保护的网络上也是如此。所以访问已归档的电子邮件时会更安全——即使在机场或火车站等未受保护的网络或热点上也是如此。您可以在这里找到有关Let’s Encrypt工作原理的更多信息。